Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #4580
    deplume
    Participant

    Hi. I have a form with 4 checkbox fields in it. These checkbox fields have a lot of options. Here’s a list of issues I’m facing while displaying the form and saving the form-
    1. The page alignment goes haywire when there are a lot of checkbox options
    2. All Checkboxes display only NA on page.
    3. In the backend, I could see the data being consolidated for all the checkbox fields and saved in “wp_bepro_listings_form” as one “checkboxes” field-

    {“save_bepro_listing”:”1″,”bepro_post_id”:””,”redirect”:””,”item_name”:”RHO Directory Contact”,”first_name”:”test”,”last_name”:”testlst”,”email”:”[email protected]”,”address_line1″:”764734″,”city”:””,”state”:””,”country”:”India”,”postal”:””,”phone”:””,”website”:””,”text”:””,”text2″:””,”text3″:””,”text4″:””,”text5″:””,”number_text”:””,”text6″:””,”Textarea”:”Testing purpose Only”,”Textarea9″:”Testing purpose Only”,“checkboxes”:[“Bi Men”,”Clinical research”,”Aboriginal Health”,”Undergraduate Students”],”origami”:””}

    This is the link, please observe “Other” section – New Form

    • This topic was modified 6 years, 9 months ago by deplume.
    • This topic was modified 6 years, 9 months ago by deplume.
    #4583

    Hi,

    This post has been moved to the Form Builder forum

    Help us to confirm that we understand your concerns by answering the following.

    1) We are not able to see the “NA” issue with the link you shared. Can you share a screenshot?
    2) Are you having issues with the layout of checkboxes when you use lots of them?
    3) What backend are you referring to? Can you share a screenshot of the saved data?
    4) Which version of the Form Builder are you using?
    5) Is there anything we missed in #1-4?

    ___
    BePro Software Team

    #4626
    deplume
    Participant

    Hi, Here are the screenshots –

    Here’s the main page in discussion. You may scroll down and can see the checkbox fields.

    1) After saving, when I view the listing it doesnot show me the checkbox options I saved, rather NA – Screenshot
    2) Checkboxes alignment issue
    3) I have four different fields with lots of checkbox options. In my opinion, all the checkboxes should be saved seperately like checkbox-field-1: {abc,ssd,ffg}, checkbox-field-2: {xxy,nnj} but currently in bepro it’s saving like checkbox-field: {abc,ssd,ffg,xxy,nnj}. Combines all the options selected from front end for different checkboxes. Screen shot of database- click here
    4) Form Builder version 1.0.32

    #4627

    Hi,

    1) The form builder is designed to show “NA” for empty selections. Are you observing this and requesting that it work differently?

    2) Thanks for sharing this layout issue. We will work on creating a style that prevents that type of overlapping issue. A never version is scheduled this week which will hopefully address this.

    3) Yes, each checkbox group should have its their own object in the json string which is saved to the database. We will investigate

    ___
    BePro Software Team

    #4630
    deplume
    Participant

    1) The form builder is designed to show β€œNA” for empty selections. Are you observing this and requesting that it work differently?

    I understand that but it’s the bug in point 3) which causing trouble for even the checkbox data to be displayed as NA despite the fact that there’s data for it.

    2) Thanks for sharing this layout issue. We will work on creating a style that prevents that type of overlapping issue. A never version is scheduled this week which will hopefully address this.

    Thanks for looking into this and making it work out this week.

    3) Yes, each checkbox group should have its their own object in the json string which is saved to the database. We will investigate

    Would it be possible to have this bug fixed alongwith this weeks release. Highly appreciated.

    Thanks much for looking into this so far. πŸ™‚

    • This reply was modified 6 years, 8 months ago by deplume.
    #4632
    deplume
    Participant

    Also if you could fix this mentioned earlier in a different post by me-
    https://www.beprosoftware.com/forums/topic/error-on-adding-a-field-with-an-apostrophe/

    This happens when I’m adding a field with apostrophe ( like Gay Men’s Health) for checkbox options. It gives error on saving the form. Would appreciate if you can push this fix too for this week.

    Thanks.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.