Home Forums BePro Listings Help with [filter_form] Shortcode

This topic contains 35 replies, has 2 voices, and was last updated by  BePro Software Team 4 years, 11 months ago.

Viewing 15 posts - 16 through 30 (of 36 total)
  • Author
    Posts
  • #2698

    Hi,

    Which version of BePro Listings Search is showing up on the plugins page?

    ___
    BePro Software Team

    #2699

    STEVE
    Participant

    1.0.02

    #2700

    STEVE
    Participant

    After installing the latest BePro Listings update when I do a search for US I get the “your criteria returned no results” message.

    #2705

    Ok,

    Are the results stored as US or USA or United States?

    #2707

    STEVE
    Participant

    US. It was finding US listings before these recent updates were installed.

    #2713

    STEVE
    Participant

    Guys, do you plan on helping me out here?

    First, you said in an earlier post “There is a new version of the free BePro Listings and the paid search addon. In the admin addon menu, there will be a new search tab. Make sure the “Exact Search” option is checked”.
    However, when I explained to you that I never saw this “new search tab” or “Exact Search option” you never addressed this.

    Second, as mentioned in a previous post of mine, since one of the latest BePro Listings updates has been installed, my location search in no longer able to find any listings in “US”.

    I am up to date on the latest version of the BePro Listings plugin, and I test the location search very time and no change. Still won’t find US listings.

    Things seem to be just getting worse. Please Help.

    Thank you.

    #2716

    Hello,

    In post #2672 we explained how our search retrieves and compares geo information by radius.

    In post #2673 you stated “I don’t want to constrain the search to a specific radius”. So you were offered a solution which does no geo-targeting whatsoever.

    So in this configuration, search will not work unless the search criteria is exactly what is stored.

    Regards
    ___
    BePro Software Team

    #2721

    STEVE
    Participant

    I have two problems that I need addressed.
    1)
    In post #2685 you said “There is a new version of the free BePro Listings and the paid search addon. In the admin addon menu, there will be a new search tab. Make sure the “Exact Search” option is checked”.

    However, as I explained to you in post #2692, I don’t see this “new search tab” or “Exact Search option”. I am using the latest BePro Listings plugin and I even re-downloaded and re-installed the “Paid” search addon. Am I doing something wrong? How can I see these new things you mentioned?

    2)
    Since I updated the BePro Listings plugin to version 2.1.40 (September 2nd, 2014), my location search is no longer working. I use to be able to type “US” or “Dominican Republic” in the “Where” search field and it would pull up results for either search. But now all I get is the “your criteria returned no results” message. So to be clear, before version 2.1.40 was installed this particular search worked. After version 2.1.40 was installed, this particular search doesn’t work. I even tried removing the [filter_form listing_page="mylistingpage" geo="0"] shortcode which I was experimenting with and that made no change, the search is still not working. I even installed the two latest plugin updates, 2.1.41 and then 2.1.42 and tried the search with both of the update installs and the problem persists. Please help. You already have an account to my site so you can log in to test it for yourself. http://nextstar.net/starbase/

    Thanks.

    #2732

    Hi,

    Lets address the first issue as it may help with the second.

    This missing menu item is an issue with the plugin. Our apologies for any confusion or issues this may have caused. We have addressed the issue in the latest release BePro Listings Search 1.0.03

    Please install this version, follow the instructions from post #2685 and let us know if you get better results from the search.

    Regards
    ___
    BePro Software Team

    #2735

    STEVE
    Participant

    Apology accepted. I deactivated and removed the previous version of the Search add-on. I downloaded and installed the updated Search add-on. I now see the new “AddOns” menu and the “Exact Search” option, which as you instructed, I did activate.

    I am now able to find the “US” listing by searching for US and the “Dominican Republic” listing by searching for Dominican Republic. However, the “Where” search is NOW no longer able to find ANY of the other location searches that were working just fine prior to the latest updates. For example, these searches are no longer working.
    – State Search. I use to be able to find states by typing NY, NJ, or CA. Not any more.
    – City Search. For example, I have a listing in Los Angeles. I can’t find it via search.
    – Zip Code Search. Also not working any longer.

    Please fix this.
    Thank you.

    #2740

    Hi,

    Thanks for the confirmation.

    As requested and discussed in post #2716, we have provided a configuration which removes all features related to radius/distance. We do not and cannot translate all variations for every, city, state and country on the planet.

    Google translates your query into a lat/lon. We then compare that mathematically to the lat/lon information that’s stored for every listing. The mathematical calculation is based on radius. So, if you remove the distance aspect as you requested, the features you described in #2735 will be lost.

    I recommend you wait for the “Search Links” feature we discussed previously in the following post

    http://www.beprosoftware.com/forums/topic/where-search-as-hyperlink-possible/

    There will also be an added feature to replace the “where search” with checkboxes related to the created “search links”. This would directly address the variation issue, by forcing users to select specific locations

    Regards,
    ___
    BePro Software Team

    #2746

    STEVE
    Participant

    If you refer back to the very first sentence of the very first post (#2611) I made to open this thread, you will read that I stated, “Now that we have the [search_form] shortcode working just right I’m trying to enhance my BePro listings search feature just a bit by now adding the [filter_form] shortcode.”

    We have been though a lot together to get that [search_form] to work as it should. As you recall I discovered several issues throughout the process which in turn lead you to release updates to fix the issues I discovered. But in the end, it finally worked, all the issues were resolved. I was happy and you had a more solid product in BePro Listing. I even purchased the Search add-on upon your recommendation and that turned out to be helpful as well.

    Then I guess I got a little too greedy and decided I wanted to go ahead and enhance my BePro Listing setup with the other feature it offers, the FILTER. The SEARCH feature was working great, so the next logical step would be to try the FILTER feature. It makes sense, you SEARCH to find results, then you FILTER to narrow the results down.

    However, this is when things went downhill. Here is a summery of the chaos and where I am left standing…
    1) The option to remove the distance dropdown from the [filter_form] shortcode was not working.
    2) It turned out that option was no longer supported, and could only be removed with CSS.
    3) The CSS you provided me to remove the distance dropdown didn’t work.
    4) I tried to just keep the distance dropdown and use the “None” option to see if it would work.
    5) The “None” option didn’t seem to work with the Filter, see post #2673 for details.
    6) In response to my explanation in post #2673 of why I believed the Filter was not working, you told me of a “new version of the free BePro Listings and the paid search addon” (Post #2685).
    7) After I installed the update to BePro Listings my “Where” search was no longer able to find listing for Country. This was even before the BePro Search upgrade was available for install.
    8) Two more BePro listings updates were released but still the search could not find by Country.
    9) The BePro Search addon update was made available and I installed it as you suggested.
    10) Now the search was able to find Countries that I search for (US and Dominican Republic) but instead now none of the other searches worked. See post #2735.
    11) In your last post to me (#2740) you explained “we have provided a configuration which removes all features related to radius/distance.” You then go on to explain “So, if you remove the distance aspect as you requested, the features you described in #2735 will be lost.” I gather that you are referring to the “Exact Search” option in the admin AddOns menu on the new search tab. So I went and “unchecked” this new option to turn it off. I figured that would put things back to the way they should be, as in before that option was available, as in before this doomed thread was even started. But… the bad news is the “Where” search is NOW completely and utterly broken. Please log into my site and see what I’m talking about (link below). You can’t search for anything with the “Where” field. It sometimes will find one listing here or there. But it’s just broken. PLEASE PLEASE PLEASE HELP. Getting BePro Listings working just right is the only thing that is holding up the launch of my new site/new business. I BEGGING YOU HERE. PLEASE FIX THIS. I honestly only wanted to ENHANCE BePro Listings with the “FILTER”. I had NO idea it would cause sooooo much trouble! I just need it to go back to the way it was before this thread was started. If that means no Filter, then no Filter! I rather have that then this broken “Where” search. :'(

    http://nextstar.net/starbase/

    #2765

    Hi,

    To revert, try either

    A) Remove the exact search option from the Search admin tab
    B) Deactivate the search addon

    Let us know which option provides the desired search results

    Regards,
    ___
    BePro Software Team

    #2774

    STEVE
    Participant

    As I said above in my last post..

    “I gather that you are referring to the “Exact Search” option in the admin AddOns menu on the new search tab. So I went and “unchecked” this new option to turn it off.”

    This didn’t help.

    I just went and deactivated the Search Addon as you just suggested. This also didn’t help.

    The “Where” searchs is still completely broken as I described at the end of post #2746 above.

    Please Help.
    Thanks.

    #2777

    Hi,

    We will continue to review this issue and update this post when a solution is found. However, if your situation needs immediate attention, you should consider contacting us via email for a quote on purchasing development hours.

    Regards
    ___
    BePro Software Team

Viewing 15 posts - 16 through 30 (of 36 total)

You must be logged in to reply to this topic.