Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #3802
    philmay
    Member

    Only some fields are working in the form builder addon. For example, file upload will not work. I can not add it to the form, when i click file upload it does nothing at all. I tried deleting the existing file upload field in the default form and adding it again and it will not add to the form even then.

    so far these fields will not work:
    Categories
    File Upload
    Description
    Submit Button

    I found this java error on the form builder page in admin:

    Uncaught TypeError: Cannot read property ‘add’ of undefined
    http://www.meshgeo.com/wp-content/plugins/bepro_listings_form_builder/vendor/js/jquery-ui-dragable-1.10.4.js line 585

    i think this is typo related, it should be jquery-ui-draggable-1.10.4.js with 2 g’s

    • This topic was modified 9 years, 2 months ago by philmay.
    • This topic was modified 9 years, 2 months ago by philmay.
    #3806
    philmay
    Member

    ok changing the file name to the correct spelling got rid of that java error but the fields still do not work

    #3807
    philmay
    Member

    your plugin throws this error on the formbuilder admin page:

    SAVEQUERIES must be defined to show the query log.

    Database Errors

    SELECT * FROM wp_bepro_listings_form_fields WHERE id=
    You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ” at line 1

    #3808
    philmay
    Member

    `NOTICE: wp-content/plugins/bepro_listings_form_builder/bepro_listings_form_builder.php:109 – Undefined index: action
    require_once(‘wp-admin/admin.php’), do_action(‘admin_init’), call_user_func_array, Bl_form_builder->start_checks

    NOTICE: wp-content/plugins/bepro_listings_form_builder/bepro_listings_form_builder.php:117 – Undefined index: action
    require_once(‘wp-admin/admin.php’), require_once(‘wp-admin/admin-header.php’), do_action(‘admin_head’), call_user_func_array, Bl_form_builder->start_header

    NOTICE: wp-content/plugins/bepro_listings_form_builder/bepro_listings_form_builder.php:121 – Undefined index: bl_form_id
    require_once(‘wp-admin/admin.php’), require_once(‘wp-admin/admin-header.php’), do_action(‘admin_head’), call_user_func_array, Bl_form_builder->start_header

    NOTICE: wp-content/plugins/bepro_listings_form_builder/bepro_listings_form_builder.php:282 – Undefined index: action
    require_once(‘wp-admin/admin.php’), require_once(‘wp-admin/admin-header.php’), do_action(‘admin_head’), call_user_func_array, Bl_form_builder->start_header, include(‘/plugins/bepro_listings_form_builder/dist/bl_form_builder.php’), do_action(‘bl_form_admin_edit_details’), call_user_func_array, Bl_form_builder->admin_edit_details

    NOTICE: wp-content/plugins/bepro_listings_form_builder/bepro_listings_form_builder.php:291 – Undefined index: bl_form_id
    require_once(‘wp-admin/admin.php’), require_once(‘wp-admin/admin-header.php’), do_action(‘admin_head’), call_user_func_array, Bl_form_builder->start_header, include(‘/plugins/bepro_listings_form_builder/dist/bl_form_builder.php’), do_action(‘bl_form_admin_edit_details’), call_user_func_array, Bl_form_builder->admin_edit_details

    NOTICE: wp-content/plugins/bepro_listings_form_builder/bepro_listings_form_builder.php:296 – Undefined variable: form
    require_once(‘wp-admin/admin.php’), require_once(‘wp-admin/admin-header.php’), do_action(‘admin_head’), call_user_func_array, Bl_form_builder->start_header, include(‘/plugins/bepro_listings_form_builder/dist/bl_form_builder.php’), do_action(‘bl_form_admin_edit_details’), call_user_func_array, Bl_form_builder->admin_edit_details

    NOTICE: wp-content/plugins/bepro_listings_form_builder/bepro_listings_form_builder.php:301 – Undefined variable: bl_form_id
    require_once(‘wp-admin/admin.php’), require_once(‘wp-admin/admin-header.php’), do_action(‘admin_head’), call_user_func_array, Bl_form_builder->start_header, include(‘/plugins/bepro_listings_form_builder/dist/bl_form_builder.php’), do_action(‘bl_form_admin_edit_details’), call_user_func_array, Bl_form_builder->admin_edit_details

    NOTICE: wp-content/plugins/bepro_listings_form_builder/bepro_listings_form_builder.php:171 – Trying to get property of non-object
    require_once(‘wp-admin/admin.php’), require_once(‘wp-admin/admin-header.php’), do_action(‘admin_head’), call_user_func_array, Bl_form_builder->start_header

    NOTICE: wp-content/plugins/bepro_listings_form_builder/bepro_listings_form_builder.php:381 – Undefined index: action
    require_once(‘wp-admin/admin.php’), do_action(‘bepro_listings_page_bepro_listings_form_builder’), call_user_func_array, Bl_form_builder->bepro_listings_form_builder

    #3810

    Hi,

    Thanks for contacting us with this issue. I can understand your frustration, lets see if we can help you.

    Right away i kindly request that you return the js file to its original spelling with (1 g). This naming correctly references that packaged js file.

    The php notices you posted paint a different picture. Are you able to freely manipulate those form fields when creating a new form?

    Regards
    ___
    BePro Software Team

    #3812
    philmay
    Member

    i had changed both the call to the file and file but the problem persisted. I changed them back. Any idea why all these errors are occurring?

    yes creating a new form the fields were useable.

    • This reply was modified 9 years, 2 months ago by philmay.
    #3814

    Hi,

    Great to hear that creating a new form worked.

    Yes, we do have an idea of whats going on with your installation. It seems php related and we are working on an upgrade. Luckily, I can see that you already have the “BePro Software Upgrades” plugin downloaded. This will make upgrading very easy.

    A member of our team will update this post when the new version of the form builder is released with a fix for your issue. You can expect this update to be released today.

    Regards
    ___
    BePro Software Team

    #3816
    philmay
    Member

    you guys have excellent support thank you for addressing these issues. It is refreshing to see such precise and prompt support, something you dont usually get even with paid plugins.

    #3820

    Hi,

    Thanks for the feedback! Always nice to have hard work noticed 🙂

    A new version of the form builder is available 1.0.26. You should see the update button available in the wordpress admin plugin panel. Please confirm that this new version has fixed the issue

    Regards
    ___
    BePro Software Team

    #3823
    philmay
    Member

    any luck? I am getting this on single listing pages also and the display is completely messed up:

    WARNING: wp-content/plugins/bepro_listings_form_builder/bepro_listings_form_builder.php:1012 - array_values() expects parameter 1 to be array, null given
    require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), get_single_template, get_query_template, apply_filters('single_template'), call_user_func_array, Bepro_listings->post_page_single, include('/plugins/bepro-listings/templates/single-listing.php'), include('/plugins/bepro-listings/templates/content-single-listing.php'), do_action('bepro_listings_item_details'), call_user_func_array, bepro_listings_item_details_template, apply_filters('bepro_listings_override_page_content'), call_user_func_array, Bl_form_builder->details_page, array_values
    #3831

    Hi,

    As mentioned in another post, the display issue is probably by the need for you to create a template file for BePro Listings. This is explained on the following documentation page

    https://www.beprosoftware.com/documentation/bepro-listings-template-files/

    A team member is evaluating the error

    ___
    BePro Software Team

    #3834
    philmay
    Member

    As shown in another post I have created a template and that is not the problem. I would really like this fixed today, I have now spent $80 on your plugins and still have no useable product as I am stuck spending all my time trying to fix php and javascript errors.

    • This reply was modified 9 years, 1 month ago by philmay.
    #3836

    Hi,

    You are right. We notice your patience and appreciate the opportunity to address these issues.

    A new version of the form builder (1.0.27) has been released today, addressing this php error. Please confirm that its now fixed

    ___
    BePro Software Team

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.